Back to overview
Degraded

Something is not quite right with billing calculation

Aug 23 at 02:00am EEST
Affected services
Billing

Resolved
Aug 28 at 01:00am EEST

Billing calculation and real-time balance indication features are back!

Created
Aug 23 at 02:00am EEST

We've detected double-charges for some infrastructure-related services (container service & network load balancers) and stopped real-time updates of certain billing sub-systems until situation is carefully investigated. To secure your funds, credit card auto top ups are disabled too.